ProfiPHPProfiPHP
Категория: Прочее

Статистика посещений на Mikrotik

Представим ситуацию: вы работаете в офисе, где в качестве маршрутизатора используется Mikrotik, вы также знаете какой-то язык программирования, и вам необходимо реализовать сбор информации о посещении сайтов сотрудниками. Разберем процесс импорта статистики посещений с помощью маршрутизатора Mikrotik и простой утилиты под Windows - WebProxy-Log.

WebProxy-Log являет собой приложение, которое собирает логи с маршрутизатора Mikrotik для последующей обработки. Также данная программа имеет интерфейс просмотра журналов. Самое важное получить данный файл логов, а потом уже, с помощью созданного скрипта, можно выводить статистику в нужном нам формате.

Открываем панель управления маршрутизатором Mikrotik через Winbox. Далее вкладку "IP => Web Proxy". На вкладке General устанавливаем галку рядом с Enabled и вводим параметры точно так же, как на изображении:

Далее заходим в "System => Logging". На вкладке Action нажимаем на "+". Поле "Name" изменяем на "WebProxyLog", "Type" изменяем на "remote". В поле "Remote Address" пишем адрес компьютера на котором установлена программа WebProxy-Log.

Переходим во вкладку "Rules", нажимаем на "+". В поле "Topics" выбираем "web-proxy", в поле "Prefix" пишем "Proxy", а на вкладке "Action" выбираем "WebProxyLog".

Теперь открываем New Termenal и пишем правило для NAT:
/ip firewall nat add action=redirect chain=dstnat comment="Redirect port 80 request to Web Proxy" disabled=no dst-port=80 protocol=tcp to-ports=8080
И открываем UDP порт под номером 514.
/ip firewall nat add action=dst-nat chain=dstnat dst-port=514 protocol=udp to-addresses=192.168.1.50 to-ports=514
На данном этапе настройка Mikrotik завершена. Теперь передаем эстафету программе WebProxy-Log.

Устанавливаем и запускаем программу, после чего в окне "General settings" указываем IP address: 192.168.1.50. "UDP Port" указываем 514, "Buffer" указываем "400", "Write log to" Указываем путь на каталог, где будет лежать файл журнала, в параметре "Import from" указываем путь на каталог, откуда будет импортироваться файл журнала, путь "DB location" оставляем по умолчанию.

Если файлы логов не создаются, проверьте параметры брандмауэра. Должен быть разрешен для входящих соединений 514 порт по протоколу UDP.

Далее с помощью программы мы можем получать статистику посещений, но, самое главное, у нас каждый день формируются текстовые файлы с записями логов, которые мы можем разбирать в любом необходимом нам формате.

Добавить комментарий

Имя:
Текст комментария: